Page 1 of 1

Server migration yesterday

Posted: Thu Aug 20, 2009 8:33 pm
by Bieneke
Hi all,

Yesterday, the forum was down for several hours and until early this morning, visitors to this site could occasionally see strange welcome screens (like "log in to the server" :eek: ). That was caused by my bold plan to move this website to another server, one that has php5 instead of php4. Normally, my webhost would do that for me, but then I would have to wait until December (when all sites on our shared server will be moved). I did not want to wait that long - for several reasons - so I migrated this site myself. Being a laywoman, of course, I encountered several glitches :o so that was what caused the inaccessibility of this site yesterday. Before I took the forum down, I had started to write an explanation in this subforum, but it turned into a story about silly procedures for changing your DNS, htaccess files that spontaneously disappear, and so on. Halfway my rant, I decided I would just leave a message on the board saying it would be back online within a few hours.

Everything works fine now, but of course, you already noticed that. Next time I undertake such a daring project, I will inform you in advance!

Re: Server migration yesterday

Posted: Fri Aug 21, 2009 12:29 am
by Grytolle
Latest posts works, but it looks messed up

Re: Server migration yesterday

Posted: Fri Aug 21, 2009 8:11 am
by JazzedPotato
Grytolle wrote:Latest posts works, but it looks messed up

Hmmm what do you mean Grytje? :) It looks the same for me? (using IE8/ Vista).

The only problem I had was that when making corrections yesterday, I was unable to scroll down very well
when the message got long. I didn't have this problem before the migration. :)

Anyway thanks Bieneke for your extra trouble migrating us sooner. ;)

Re: Server migration yesterday

Posted: Fri Aug 21, 2009 11:54 am
by Grytolle
http://upload.digiex.net/files/4zirodcw7l3z8a9w5g3e.png

The same thing for messages like "you logged in", "you've been logged out", etc

edit: successfully posted-message too


edit2:
so basically it should have to do with the class used here:

Code: Select all

<div class="panel" id="message">
	<div class="inner"><span class="corners-top"><span></span></span>

	<h2>Informatie</h2>
	<p>Je bericht is succesvol bewerkt.<br /><br /><a href="./viewtopic.php?f=3&t=2893&p=17966#p17966">Toon het geplaatste bericht</a><br /><br /><a href="./viewforum.php?f=3">Keer terug naar het laatst geopende forum</a></p>
		<span class="corners-bottom"><span></span></span></div>
</div>

Re: Server migration yesterday

Posted: Fri Aug 21, 2009 12:39 pm
by Bieneke
I know what you mean, Grytolle - thanks for the screenshots. My screen has the same dimensions as yours and on such a screen, it is very noticeable that the tables are suddenly shorter (narrower). Right after the server migration, I checked the forum in IE and noticed that all text was centered. When I fixed that, I must have done something that affected the table width. Funny enough: I did not touch the code you quoted or the related css files (although the span tags look messy; they were already that way before). I will check the files that I did edit to see what could be the reason.

Re: Server migration yesterday

Posted: Fri Aug 21, 2009 2:03 pm
by JazzedPotato
Grytolle wrote:http://upload.digiex.net/files/4zirodcw7l3z8a9w5g3e.png
The same thing for messages like "you logged in", "you've been logged out", etc
Well I use a different resolution so it was not as noticeable to me as in your png-screenshot. :)
And I never log out normally so didn't see it there either.
edit: successfully posted-message too
True this I have noticed also.

I think the not being able to scroll down on a larger post when editing or changing it is more
noticeable though. I have tried it again today and for me the scrolling down doesn't work, it
keeps bringing back the cursor to the beginning of the post.. :-?

Can this be fixed too, Bieneke?

Re: Server migration yesterday

Posted: Fri Aug 21, 2009 2:19 pm
by Bieneke
JazzedPotato wrote:I think the not being able to scroll down on a larger post when editing or changing it is more
noticeable though. I have tried it again today and for me the scrolling down doesn't work, it
keeps bringing back the cursor to the beginning of the post.. :-?
That is strange! I just tested it (in Firefox 3.5.2 and IE8); I edited a long post and the cursor did not jump back to the beginning when I scrolled down.

- What version of IE are you using?
- Is this a new bug (appeared only yesterday) or did you experience it before?

Re: Server migration yesterday

Posted: Fri Aug 21, 2009 3:15 pm
by JazzedPotato
Bieneke wrote: That is strange! I just tested it (in Firefox 3.5.2 and IE8); I edited a long post and the cursor did not jump back to the beginning when I scrolled down.

- What version of IE are you using?
- Is this a new bug (appeared only yesterday) or did you experience it before?

Hmm I am using IE8 on Vista.

No I did not experience this before the migration. In fact things were stable after your last upgrade and my own
upgrade to IE8. :) It happened to me twice when editing a post/correction for L3ho.

Just tested it again but it keeps jumping back to the beginning of the post. If I try to
select a word at the end of the message e.g. the cursor keeps jumping back to the beginning.

Re: Server migration yesterday

Posted: Fri Aug 21, 2009 3:59 pm
by Bieneke
That must be so annoying! I just tested it again on Vista/IE8, and this time, the same thing happened. If you move your mouse out of the text field (even without clicking anywhere), the cursor automatically jumps back to the beginning of the post. I will dig into the files to see what code is responsible for that. I have no idea why the cursor/scrollbar suddenly started behaving that way.

In the meantime, just try to keep your mouse in the text field when you are navigating through the post.

Re: Server migration yesterday

Posted: Fri Aug 21, 2009 4:56 pm
by bokassa
Current PHP version is 6, so you should better start doing your homeworks now...

I had the same problem (php4 to 5) back in 2005!

Maybe it would have been better to upgrade the forum software first and then do the migration...

Re: Server migration yesterday

Posted: Fri Aug 21, 2009 5:50 pm
by Bieneke
I just searched the internet and found out that it is a known bug in IE8. There is a patch for phpbb (which was already implemented on the pre-server migration forum), but it does not seem to solve the problem for me (but why did that patch work before? :-? ). The patch makes IE8 display the page in an IE7 compatible view. You can also do that manually by going to Tools > Compatability View Settings in IE8. Add 'dutchgrammar.com' to the list. That is why I did, but the scrollbar still jumps to the top when I reach the bottom of the message. Somehow, IE8 does not like posts that contain 100 lines or more.

I have tried all sorts of suggestions that I found on the internet, but none of them worked. I am now going to update IE8 (I noticed a compatibility update) and see what happens.
bokassa wrote:Current PHP version is 6, so you should better start doing your homeworks now...

I had the same problem (php4 to 5) back in 2005!
I am already looking forward to all the homework. :D Until there is a stable release for php6, I prefer php5.
bokassa wrote:Maybe it would have been better to upgrade the forum software first and then do the migration...
That is what I did, and that is what puzzles me; I haven't changed anything in the forum software.

Re: Server migration yesterday

Posted: Fri Aug 21, 2009 5:52 pm
by JazzedPotato
Bieneke wrote:That must be so annoying! I just tested it again on Vista/IE8, and this time, the same thing happened. If you move your mouse out of the text field (even without clicking anywhere), the cursor automatically jumps back to the beginning of the post. I will dig into the files to see what code is responsible for that. I have no idea why the cursor/scrollbar suddenly started behaving that way.

In the meantime, just try to keep your mouse in the text field when you are navigating through the post.

Yes actually I had been doing that in the end, just using the up/down arrows, and with some persistence it works eventually.. :D

Thanx Bieneke I will wait for updates on this in future, if you can find the culprit. ;)
Bieneke wrote:I just searched the internet and found out that it is a known bug in IE8. There is a patch for phpbb (which was already implemented on the pre-server migration forum), but it does not seem to solve the problem for me (but why did that patch work before? :-? ). The patch makes IE8 display the page in an IE7 compatible view. You can also do that manually by going to Tools > Compatability View Settings in IE8. Add 'dutchgrammar.com' to the list. That is why I did, but the scrollbar still jumps to the top when I reach the bottom of the message. Somehow, IE8 does not like posts that contain 100 lines or more.

I have tried all sorts of suggestions that I found on the internet, but none of them worked. I am now going to update IE8 (I noticed a compatibility update) and see what happens.
Yes it seems to be partial to brevity.. :D

Ok, let' s see if that helps - hope so! :thumbsup:

Re: Server migration yesterday

Posted: Sun Aug 23, 2009 2:10 pm
by DominicCronin
You can get IE8 to automatically go into IE7-compatibility mode by adding the following to your page header:

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

Presumably it also works if you send it as an HTTP header.

Obviously, it would be nice to avoid doing this, but it sounds like the bug makes for a fairly unpleasant user experience, so it's worth considering.